NETIM-WHMCS-2.6

De NETIM
Aller à : Navigation, rechercher

Comptabilité

PHP 5.6 / 7.+

Ioncube 10+

WHMCS 7+

Attention, cette version n'est pas compatible avec l'API 1.5
Attention, cette version nécessite la version de ioncube 10


Change log de la 2.6.6

- Correction d'un bug dans 8.0.3 concernant la synchronisation des domaines


Change log de la 2.6.5

Module

- Support de la fonctionnalité "TLD Import & Pricing Sync"

- Correction du non chargement du widget dans certaines versions de PHP / Ioncube loader

NETIM TLD manager

- Correction de l'anomalie si des groupes de clients sont définis. La mise à jour des prix des extensions se fait désormais sur le groupe par défaut

- Correction d'une anomalie dans l'affichage et le calcul dynamique de la marge lorsque la devise de base n'est pas l'Euro

- Ajout de l'application de la marge par défaut sur les extensions sélectionnées. Le bouton de mise à jour initial devient "Update with manual prices"

- Ajout de l'importation des prix


Change log de la 2.6.3

- Correction d'une autre anomalie dans la gestion des contacts si définis dans les paramètres généraux


Change log de la 2.6.2

- Correction d'une anomalie dans le chargement des prix dans l'addon NETIM_TLD_MANAGER

- Correction d'une anomalie dans la gestion des contacts si définis dans les paramètres généraux

- Remplacement du caractère " par ' systématique dans les informations de profil


Change log de la 2.6.1

- Correction d'un bug mineur sur le scrypt de synchronisation

- Support des informations additionnelles sur le changement des contact.

NETIM_TLD_MANAGER

- Ajout du paramétrage "Durée minimale"

- Modification dynamique du calcul de marge sur les extensions actives

- Ajout de la mise en valeur des marges < marge par défaut

- Ajout de l'affichage de toutes les extensions dans l'ajout d'une extension

- La mise à jour des prix n'affecte plus que les périodes actuellement enregistrées (auparavant appliquait l'ajout)

- Modification de la notion de "taux de marge par défaut" en "taux de marge par défaut sur prix de vente"


Amélioration

  • Revue et test de compatibilité

Cette version du module unique a été testée pour fonctionner sur toutes les versions de PHP depuis 5.6


  • Fonction de suppression d'un domaine

L'exécution de l'opération de suppression a été revue afin de gérer correctement les différentes situations impactant les dates d'expiration et le statut.


  • Nouvel addon "netim_tld_manager"

Suite à de nombreuses demandes à ce sujet, nous sommes fier de fournir dans le module un addon permettant une gestion efficace des extensions notamment:

- Visualiser les extensions actives, le prix d'achat, le prix de vente actuel et réaliser une modification en masse

- Ajouter des extensions en 1 clic

- Vérifier le paramétrage des extensions vs les valeurs acceptées par NETIM

- Visualiser les promotions


  • Support complet du jeu de caractères latin pour les informations du profil, titulaire et contacts

Tous les caractères accentués des jeux LATIN1 / LATIN-EXTA / LATIN-EXTB

Le support d'autres jeux de caractère tels que le Cyrillic n'est pas supporté.


  • Support des fonctions "domain_sync" et "transfer_syc"

La synchronisation des domaines notamment au niveau de la date d'expiration et du statut est désormais réalisée par le fonctionnement interne de synchronisation des domaines de WHMCS ainsi que la synchronisation des transferts de domaine.

L'ancien script de synchronisation netimsync.php n'est désormais plus utilisé.

Le nouveau script netim_opesync.php doit par contre être utilisé pour synchroniser les enregistrements et les renouvellement asynchrones.


Corrections d'anomalies

  • Conversion des champs additionnels de l'extension .IE

Le gestion du processus d'enregistrement via le fastpass était incorrecte


  • Gestion des domaines IDN

L'enregistrement d'un domaine en IDN réalisait l'enregistrement d'un domaine différent suite à une erreur de conversion


Installation

En cas d'évolution depuis une version précédente du module, veuillez modifier la planification du script de synchronisation

En cas d'évolution depuis une version utilisant l'API 1.5, veuillez modifier l'URL de l'API dans le paramétrage du module avec la valeur ci dessous


Fichiers WSDL de production

L'utilisation de cette version est nécessaire

API 2.0

Outils personnels
Espaces de noms

Variantes
Actions
Votre compte
Noms de domaine
Hébergement mutualisés
Anciennes offres d'hébergement
Certificats SSL
Revendeurs
Affiliation
Contacter le support
Divers